Strange issue with links and page_id on IE8 IE9 browser error

Latest Reply from PixelJockey at 2013-10-06 22:30:58 Solution
I am having url string issues with RealEstater theme on IE8+ browsers only. Every time I click on a link and then the back button it breaks the page it tries to load.

Here is what happens:

When a user clicks on a link and loads a page or a post and then clicks on the back button, the browser (IE) loads the following string:


Also every time I click on a link it appends "#" to the URL instead of just "?page_id=83" (for example)

Does anyone know why this happens in IE ONLY??? This does not happen in Firefox or Chrome.

Thanks for the help!
Here is the site with the issue:
Please, download our theme again from our website and replace the file js --> hashchange.js with hashchange.js from the archive. We have updated this file.
Thank you for the solution. That helps a lot!
I just updated hashchange.js (new Sept 2013 update) and it is still doing the same thing. Do I need to update in more than one location.

../wp/wp-content/themes/realestater/js/ <---- This is the location

I have the new one up there but, it looks like it is still doing the same thing in IE 9.

Any help or any additional instructions to make the error go away?

I have the same issues with the theme Beauty-secrets, and just with IE.
Can we have some help to make the error go away? It's make me crazy, I thought it's because of my wordpress multisite installation and I did it twice... Until I thought to desactive the theme "Beauty-secrets"
Her is the url of my site
Hi, PixelJockey,

Try this, it worked for me :
turn off "Load content Dynamically" and "Load posts dynamically" in the Layout page of your theme. I have a different theme tan you, but maybe it'll help you. Good luck!
Thanks for the tip @staam. It worked like a charm. Different themes but same parameters for the theme structure.


Leave a reply

Add codeAdd image