Disable seo

Latest Reply from Alice at 2015-06-18 06:28:26 Solution
I want to disable seo from my site, i have all in one seo pach plugin and have conflict with seo from womanish theme, help me.
This image is exemple of conflict.
Please, delete the following text:
echo "<title>".sprintf($format,$title)."</title>\r\n";
echo '<meta name="Description" content="'.preg_replace('/[\'\"]/', '',$descr)."\" />\r\n";
echo '<meta name="Keywords" content="'.$keywords.$this->get( 'seo', 'keywords' )."\" />\r\n";

from folder inc--> library.php located in the directory of theme.
If i delete that my site is white.
Parse error: syntax error, unexpected '=' on line 368
Could you send me your edited library.php file via email?
yes, send me your email, my email is kadytgv@gmail.com
Our team provides a support via support@smthemes.com.
We will send you an email.
I got the same error message when I tried this too. Was the above ever resolved? What had to be done?



Could you give us the URL of your website, theme name and the version of it.
Sure, it is www.ejandsonsmoving.com and it is the Flowers theme 2.2. I actually posted a new thread about this. I found similar code in this theme's library.php like what was mentioned above and removed it. It did remove the metas, but when I went in to sign into wordpress, the login and password fields were blank. So, I put the file back the way it was.

Is there an option to turn off "Built-in SEO" on page Theme Settings --> SEO?
Not that I see, just a bunch of <noindex> settings that are already off.
I was able to find code similar to the code specified above for the Flowers theme, but it was only for the description and keywords, and I removed it ok. But, the title wasn't part of it. Is the title removed a different way in this theme?
You would better update the theme to the version 2.4. There is a special option to disable this SEO feature through the dashboard without code editing.
Ok, cool, I will try that.

Is there also an update the Alium theme with the same disable option?

Yes, of course. All the themes were updated.

The person who built the site for us is no longer available, so we don't have access to the updated Flowers theme. Where can I go into the code to remove the <title>? I was able to removed the description and keywords, but the title must be somewhere else?


You have theme version 2.2 on your website, which has a different code for showing title, than current version 2.4.2. You can use latest version and only remove code from the functions.php. But as I can see you have a lot of customization on your website. So can just try to wrap
<?php wp_title( false ); ?>
in the file header.php in the <title> tag. Just replace 43rd string
<?php wp_title( false ); ?>
<title><?php wp_title( false ); ?></title>

Leave a reply

Add codeAdd image