Anchor links

Latest Reply from Dave at 2015-06-29 03:24:25
Hi. I am unable to make anchor links work properly: instead of scrolling down in the same page it looks for a new one adding anchor's name at the end of the URL... which, obviously, is a non existing page (I even get 404 error). Where am I doing wrong?
Please, give us the URL of the website.
First title, first word "Costruzioni" should scroll down to "Customer satisfaction" but it does so only for a couple of seconds than re directs to the page "customer" which doesn't exist, it is just the name i gave to the anchor link.
Sorry, i forgot to say i am using "TinyMCE Advanced" the procedure i follow is this:
- select the word anchor link should point to and click on the anchor icon to give it a name
- select the word that triggers the link, click on add link icon and put on URL the following: #+name of anchor i chose earlier
Hope it helps.
Probably, this is caused by the work of your third-party plugins. Please, try to disable your plugins one by one to detect the problem.
Having the same issue with the baseball theme i post in this topic.
Having a link with an anchor on a page, by clicking the link it get's redirected to the same link without the anchor, this leads to an 404 error.
Eg. "" the link is "" get's redirected to "" witch leads to 404 error.
I deactivated all plugins, same behaviour. I changed to theme "twenty fifteen" and the anchor link works as expected.
I expect the javescript in "/baseball/js/hashchange.js" to be the problem.
You are using an old version of the theme. Perhaps, the problem is related to this file. Try to download the latest version of the theme and replace your hashchange.js file with a new one. If this doesn't help you, you would better install the latest version of the theme.

Leave a reply

Add codeAdd image